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1.Louise is writing some LotusScript to put on an action button. She needs to access the  

NotesPropertyBroker object in the script. What Notes class is the NotesPropertyClass descended from?  

A. NotesSession  

B. NotesDocument  

C. NotesUIWorkspace  

D. NotesCompositeApp  

Answer: A   

2.When Marion is using the Property Broker Editor, what part of his composite application is he 

modifying?  

A. NSF file  

B. WSDL file  

C. Web service  

D. Action button  

Answer: B   

3.Judi is creating a Notes composite application. Her main view has a column called Nationality, and  

it is a property of her composite application. Where will she find the property attribute for that column?  

A. In the Shared Code area, under WSDL files  

B. In the Shared Resources area, under WSDL file  

C. In the Composite Applications area, under Applications  

D. In the View Column properties box, final tab under the Composite Settings area  

Answer: D   

4.Erin has been asked to add a new component, called "Tag Cloud", to his composite application.  

The component is being provided via components.nsf (based on the updatesite.ntf template).  

How should Erin proceed in adding this component to his application?  

A. Right-click the Component Palette in the Composite Application Editor. Select Add Components  

> Add NSF Component.  

B. Right-click the Component Palette in the Composite Application Editor. Select Add Components > Add 

Components from Update Site.  

C. Open the Plug-ins view in components.nsf in the Notes client. Select Tag Cloud Plug-in, and  

click the Import Database view action button.  

D. Open the Components view in components.nsf in the Notes client. Select the Tag Cloud  

component, and click the Import Database view action button.  

Answer: B   

5.If you export Wiring properties from a Notes database in Domino designer, what gets exported to a file?  

A. A WSDL file describing the Wiring properties  

B. A file in proprietary Notes rich text format  

C. A DXL file representing the Wiring Properties  

D. A binary file that can only be used for import to another Notes database  

Answer: A   
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6.Paul has added an NSF View component to his composite application, but when it displays it shows 

both the View and the list of folders and views in the database to the left of the View. How  

can he display just the view?   

A. Add "&HideNavigator" to the end of the Notes URL in the View's NSF Component Properties.  

B. Select the Hide Navigator box in theAdvanced tab of the View Properties in Domino Designer.  

C. Add an Advanced Property to the View's NSF component called  

"com.ibm.notes.view.hideNavigator" and set its value to "true".  

D. Right-click the View Component in the Composite Application Editor and select the Hide Navigator 

option in the drop-down menu.  

Answer: A   

7.Francie has developed a Component Palette in one of her composite applications that will be a good 

match for a new composite application that she is developing. How can she reuse that palette?  

A. Use theDXLExporter and DXLImporter functions to move the component palette between applications.  

B. Copy and paste the palette elements from the original composite application to the new  

composite application.  

C. Select the original composite application palette from within the new Composite Application Editor's 

Copy From menu option.  

D. Export the existing Component Palette from the original application, and then import the Component 

Palette into the new application.  

Answer: D   

8.Jacques is creating a composite application to integrate multiple components. He has his newly-created 

application open in the Composite Application Editor, and sees two of the components that he needs 

listed in the right pane. What does Jacques need to do to incorporate these components into his 

composite application?  

A. Double-click each desired component.  

B. Nothing. The listed components are automatically part of the application.  

C. Right-click each desired component and select Wire to Composite Application.  

D. Drag each desired component from the Component Palette onto the application page.  

Answer: D   

9.Composite application Properties are consumed in Views and Forms using which of the following?  

A. Agents  

B. Actions  

C. The OnSelect event  

D. The QueryModeChange event  

Answer: B   

10.Annika needs to update the WSDL file that controls the wiring between components in her composite 

application. Where would she find that WSDL file in Domino Designer?  

A. Composite Applications > Files  

B. Composite Applications > Applications  
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C. Composite Applications > Web Services  

D. Composite Applications > Wiring Properties  

Answer: D   

11.Which of the following built-in wiring data types should be used for defining Properties to ensure 

maximum compatibility between components?  

A. http:url  

B. xsd:string  

C. cai:variant  

D. notes:string  

Answer: B   

12.Theodor created new Wiring properties for his composite application, CustOrder.nsf, using Domino 

Designer. He named the Wiring properties "CustOrder", and has just finished defining the Wiring 

properties using the Property Broker Editor. What should Theodor do next to store the updated Wiring 

properties in the design of CustOrder.nsf?  

A. Close the Property Broker Editor window. As with other elements of a Domino database, the compiled 

code is automatically stored within the NSF.  

B. Select File > Save, and select File > Exit from the Property Broker Editor. With theCustOrder Wiring 

properties still highlighted in Domino Designer, select File > Save.  

C. Select File > Save, and select File > Exit from the Property Broker Editor. In the Wiring  

Properties work pane of Domino Designer, click the Refresh button, select ~CustOrder.wsdl and click 

Open.  

D. Close the Property Broker Editor window. In the Wiring Properties work pane of Domino Designer, 

select ~CustOrder and click Compile WSDL. The name updated Wiring properties are saved in the NSF 

and the name reverts to "CustOrder".  

Answer: C   

13.John has added a Managed Browser component to his new composite application. If he right-clicks 

Edit Component Properties, what options will he have for configuring the header of the component?  

A. Actions, Size, Location  

B. Color, Width, ActionBar Properties  

C. No Header, Title Bar, Title Bar with Max/Min  

D. Fixed Location, Floating Location, User Options  

Answer: C   

14.Karen is designing a composite application. When the user selects a Customer Name (from the 

Customers view of Customers.nsf), orders for that Customer should display in a separate component 

(from the OrdersByCust view of Orders.nsf).  

Where should Karen place the LotusScript that will listen for a different Customer being selected in the 

Customers view, resulting in an update of the displayed rows from the OrdersByCust view?  

A. Code should be placed in a view action of theOrdersByCust view to interact with the  

NotesPropertyBroker. The name by which the Property Broker knows this action is specified in the 

Advanced Properties of the action.  
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B. Code should be placed in theonChange event of the Name column of the Customers view to publish 

the updated Name property. The name by which the Property Broker knows this action is specified in the 

Composite Settings on the Advanced tab of the column properties.  

C. Code should be placed in theonChange event of the CustName column of the OrdersByCust view to 

interact with the NotesPropertyBroker. The name by which the Property Broker knows this property is 

specified in the Composite Settings on the Advanced tab of the column properties.  

D. Code should be placed in a view action of the Customers view to listen for the updated Name property. 

Code should be placed in a view action of theOrdersByCust view to publish the updated category name. 

Each action will need to specify the name of the affected property in the Advanced Properties of the 

action.  

Answer: A   

15.Hector wants to publish a composite application Property using the onSelect event in a Notes View. 

What does he need to do?  

A. Use the @CompositeAppPublish function to publish the Property.  

B. WriteLotusScript code that uses the NotesPropertyBroker to publish the Property.  

C. WriteLotusScript code that uses the NotesUIView.Publish method to publish the Property.  

D. None of the above. TheonSelect event can only listen for Properties published by other  

composite application components, not publish its own Properties.  

Answer: B   

16.Arne is incorporating an NSF view into his composite application. He has copied a hidden action on 

the view and has modified it to execute in response to a property change event. How must Arne modify 

the Hide attributes of his newly-coded view action to allow it to work in the composite application?  

A. Ensure that none of the options are checked.  

B. Ensure that there is a check mark by Notes, Web andMobile. Ensure that the check mark is cleared by 

Property Broker.  

C. Ensure that there is a check mark by Web andMobile. Ensure that the check mark is cleared by Notes 

and Property Broker.  

D. While it is advisable for the action to be hidden at all times, the Hide attributes are not used to 

determine when the code will execute in response to a property change event.  

Answer: D   

17.Jacob is using an NSF component in a composite application that points to a Notes view. He wants to 

change the view that is used by the component to another view in the same database. Can he do this?  

A. No, he must create a new NSF component and use that instead.  

B. Yes, he can edit the Advanced Properties of the NSF component to point to a different view.  

C. Yes, but he can only change the view name by editing the component application WSDL file directly.  

D. Yes, he can erase the Component Alias property of the original view in Domino Designer and enter the 

value as the Component Alias of the new view.  

Answer: B   

18.Harold used the New Comp App button in Domino Designer to create a new, empty composite 

application definition in his Lotus Notes database. If he sets the database launch properties to Launch As 
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Composite Application and points to the new definition, what will happen when he opens the database?  

A. The Notes client will display an error message and the database will not open.  

B. A screen will be displayed, prompting him to edit the new composite application.  

C. The default frameset will be displayed because the composite application definition is empty.  

D. The Composite Application Editor will open immediately, allowing him to edit the new composite 

application.  

Answer: B   

19.Vlade has three Eclipse components that will be part of his new composite application. He wants to 

make sure that updates to these components can be provisioned from the Domino server. What can 

Vlade do to make the components available under this situation?  

A. Store the components in the updatesite.ntf file.  

B. Store the components the Data/Eclipse directory of the Domino server.  

C. Use the updatesite.ntf Domino template to implement an Eclipse Update Site.  

D. Place a site.xml file in the composite application and give it the IP address of the component location.  

Answer: C   

20.Shelley has a composite application that surfaces a view and form from a Notes database. She would 

like to give the user the ability to maximize and minimize both of the components on the screen. Where 

does she make these changes?  

A. Within the Property Broker Editor, select Edit > Component Properties.  

B. Within Domino Designer, select Composite Applications > Advanced Properties.  

C. Within the Composite Application Editor, select Element > Advanced Property.  

D. Within the composite application, select Actions > Edit Application.Then right-click the  

component in the Component Pallette and select Edit > Component Properties.  

Answer: D  


